Você estar perdido, não sabe como configurar seu Debian “lenny”?

Versão pirata do novo Windows cai na rede 3 meses antes de lançamento
agosto 15, 2009
Um e-mail que recebi, sobre II SISOL!
agosto 17, 2009

Você estar perdido, não sabe como configurar seu Debian “lenny”?

Você estar perdido, não sabe como configurar seu Debian “lenny”?

Então eu vos apresento uma alternativa.

O primeiro passo é mudar a source.list, abra o terminal em: Aplicações >> Acessórios >> Terminal e digite o comando “su” (sem aspas) e coloque a senha senha de administrador.
Já como root digite o comando, para fazer o backup do arquivo source.list

cp /etc/apt/sources.list /etc/apt/sources.list.BAKCUP”

Depois edite o arquivo source.list digitando no terminal o comando

gedit/etc/apt/sources.list

Apague o conteudo deste arquivo e adicione estes repositorios listados abaixo: (copy and paste ou simplesmente copie e cole)

==================================================
deb http://security.debian.org/ lenny/updates contrib non-free main
deb-src http://security.debian.org/ lenny/updates contrib non-free main #Added by software-properties

deb http://volatile.debian.org/debian-volatile/ lenny/volatile main contrib
deb http://http.us.debian.org/debian/ lenny non-free contrib main
deb-src http://http.us.debian.org/debian/ lenny non-free contrib main #Added by software-properties
deb http://http.us.debian.org/debian/ lenny-proposed-updates non-free contrib main
deb-src http://http.us.debian.org/debian/ lenny-proposed-updates non-free contrib main #Added by software-properties
deb-src http://volatile.debian.org/debian-volatile/ lenny/volatile main contrib

# Repositorio principal
deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free #Added by software-properties

# Atualizacoes de seguranca
deb http://ftp.br.debian.org/debian-security/ lenny/updates main contrib non-free
deb-src http://ftp.br.debian.org/debian-security/ lenny/updates main contrib non-free

# Atualizacoes recomendadas
deb http://ftp.br.debian.org/debian/ lenny-proposed-updates main contrib non-free
deb-src http://ftp.br.debian.org/debian/ lenny-proposed-updates main contrib non-free #Added by software-properties

# Atualizacoes para pacotes que mudam com frequencia
deb http://ftp.br.debian.org/debian-volatile/ lenny/volatile main contrib non-free
deb-src http://ftp.br.debian.org/debian-volatile/ lenny/volatile main contrib non-free

# Atualizacoes alternativas para o sistema
deb http://ftp.br.debian.org/debian-backports/ lenny-backports main contrib
deb-src http://ftp.br.debian.org/debian-backports/ lenny-backports main contrib

# Pacotes multimidia
deb http://ftp.br.debian.org/debian-multimedia/ lenny main
deb-src http://ftp.br.debian.org/debian-multimedia/ lenny main
deb http://www.debian-multimedia.org/ lenny main

#XMMS packages for Debian
deb http://www.pvv.ntnu.no/~knuta/xmms/lenny/ ./
deb-src http://www.pvv.ntnu.no/~knuta/xmms/lenny/ ./

## Add this line for Opera browser
## if needed, replace etch with sarge,oldstable,stable,testing,lenny,unstable or sid
deb http://deb.opera.com/opera/ lenny non-free

## Wine

deb http://www.lamaresh.net/apt lenny main
===============================================

Salve e feche o aqrquivo modificado, pois agora vamos satisfazer as dependências das chaves que acessam os repositórios. OBS: este comando na verdade é uma série de comandos, veja o parametro &&. Só é copiar e colar no terminal o proximo comando:

# apt-get update && wget http://debian-multimedia.org/gpgkey.pub -O – | apt-key add – && apt-get install debian-multimedia-keyring && apt-get install debian-backports-keyring && wget -O – http://deb.opera.com/archive.key | apt-key add – && wget -O – http://www.lamaresh.net/apt/key.gpg | apt-key add – && apt-get update

Quem tem partições windows pode instalar Disk-Manager como o comando:

apt-get install -y disk-manager dmsetup libntfs-3g31 ntfs-3g

———————————
* Instalar Placa nvidia *
———————————

Se liga, pois aqui vai depender o kernel que esta instalado

OBESERVE QUE VC ESTA MEXENDO NO CONFIGURAÇÃO DO XORG.CONF, OU SEJA, VOCÊ VAI TER QUE CONFIGURA MOUSE, TECLADO, MONITOR, SE NÃO SABE O QUE ESTA PRESTES A FAZER, SUGIRO QUE PROCURE INFORMAÇÃO NA NET.

# apt-get install module-assistant build-essential linux-headers-2.6.26-2-686

# apt-get install linux-image-2.6.26-2-686 nvidia-kernel-2.6.26-2-686 nvidia-kernel-common

# apt-get install nvidia-glx nvidia-settings nvidia-xconfig

# apt-get install mesa-utils

# m-a a-i nvidia-kernel-source

# nvidia-xconfig

Depois de rodar e comando anteriores excute:

gedit /etc/X11/xorg.conf

E adicione:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Fri Sep  5 22:23:08 UTC 2008

Section “ServerLayout”
Identifier     “Layout0”
Screen      0  “Screen0”
InputDevice    “Keyboard0” “CoreKeyboard”
InputDevice    “Mouse0” “CorePointer”
EndSection

Section “Files”
RgbPath         “/usr/X11R6/lib/X11/rgb”
EndSection

Section “Module”
Load           “dbe”
Load           “extmod”
Load           “type1”
Load           “freetype”
Load           “glx”
EndSection

Section “ServerFlags”
Option         “Xinerama” “0”
EndSection

Section “InputDevice”
# generated from default
Identifier     “Mouse0”
Driver         “mouse”
Option         “Protocol” “auto”
Option         “Device” “/dev/psaux”
Option         “Emulate3Buttons” “no”
Option         “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier     “Keyboard0”
Driver         “kbd”
Option       “XkbRules”    “xorg”
Option       “XkbModel”    “abnt2”
Option       “XkbLayout”    “br”
Option       “XkbVariant”    “abnt2”
EndSection

Section “Monitor”
Identifier     “Monitor0”
VendorName     “Unknown”
ModelName      “Unknown”
HorizSync       30.0 – 110.0
VertRefresh     50.0 – 150.0
Option         “DPMS”
EndSection

#Section “Device”
#    Identifier     “Device0”
#    Driver         “nvidia”
#    VendorName     “NVIDIA Corporation”
#EndSection

Section “Device”
Identifier     “Card0”
Driver         “nvidia”
Option         “NvAGP” “1”
VendorName     “All”
BoardName      “All”
EndSection

#Section “Screen”
#    Identifier     “Screen0”
#    Device         “Device0”
#    Monitor        “Monitor0”
#    DefaultDepth    24
#    SubSection     “Display”
#        Depth       24
#    EndSubSection
#EndSection

Section “Screen”
Identifier     “Screen0”
Device         “card0”
Monitor        “Monitor0”
DefaultDepth    24
Option         “TwinView” “0”
Option         “TwinViewXineramaInfoOrder” “CRT-0”
Option         “metamodes” “1152x768_55 +0+0”
SubSection     “Display”
Depth       24
EndSubSection
EndSection

Depois feche o gedit e reinice a maquina.

————————
* MULTIMIDIA *
————————

Pacotes comuns que devem ser instalados:

# apt-get -y install mpeg2dec a52dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg cdda2wav toolame libmp4v2-0 totem-mozilla tagtool easytag id3tool lame libsnack2  libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox toolame  a52dec ffmpeg2theora libmpeg2-4 uudeview flac  libmpeg3-1 mpeg3-utils mpegdemux gstreamer0.10-lame libdvdcss2 libdvdcss2-dev

Codecs para o backend gstreammer 0.10

# apt-get install -y gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-sdl  gstreamer0.10-schroedinger totem-gstreamer

Mais programas para o gstreamer (opcional)

# apt-get -y install gstreamer-tools

Instalando o tocador VLC+plugins (ótimo para dvix e dvd) :

# apt-get -y install vlc vlc-nox vlc-plugin-sdl vlc-plugin-svgalib vlc-plugin-ggi

Instalando o tocador/backend MPlayer e de quebra smplayer

# apt-get -y install mplayer mencoder libqt4-dbus libqt4-designer libqt4-network libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml libqtcore4 libqtgui4 qt4-qtconfig smplayer smplayer-themes smplayer-translations

Instalando o tocador/backend XINE (outro concorrente de peso):

# apt-get -y install xine-ui gxine libxine1-plugins libxine1-ffmpeg libxine1-gnome

————–
* FLASH *
————–

O Debian já vem com uma versão de código aberto do Flash como padrão, o “Swfdec”, mas ele apesar de ter evoluído muito nos últimos tempos (tanto é que uso ele até hoje), o Swfdec se mostra um pouco incompatível com videos embarcados, vídeos “soltos” e vários conteúdos Flash mais complexos. Para resolver isso, instale o plugin da Adobe, rodando o comando (lembre-se de ter ativado o repositório “Debian Multimedia”!):

# apt-get install flashplayer-mozilla

Logo depois da instalação, selecionaremos o plugin da Adobe como a padrão. Faça isso rodando:

# /usr/sbin/update-alternatives –config flash-mozilla.so

Digite o número que está na linha relacionada ao “flashplayer-mozilla”, dando Enter em seguida, como fiz abaixo:

############################################
livre:/# /usr/sbin/update-alternatives –config flash-mozilla.so

Existem 2 alternativas que fornecem ‘flash-mozilla.so’.

Seleção      Alternativa
———————————————–
*+        1    /usr/lib/swfdec-mozilla/libswfdecmozilla.so
2   /usr/lib/flashplayer-mozilla/libflashplayer.so

Pressione enter para manter o padrão[*] ou digite o número da seleção: 2
Usando ‘/usr/lib/flashplayer-mozilla/libflashplayer.so’ para fornecer ‘flash-mozilla.so’.
############################################################

————
* JAVA *
————

Para o Java, instalaremos a versão da Sun. O IcedTea, versão código aberto do Java, ainda tem certas incompatibilidades com sites de bancos e programas como o do Imposto de Renda. Para instalar a suíte de execução e o plugin para o navegador Web, rode:

# apt-get install sun-java6-jre sun-java6-plugin &&

Após a instalação, assim como fizemos no Flash, selecionaremos esta versão do Java como a padrão. Faça isso rodando:

# /usr/sbin/update-alternatives –config java

#################################
# /usr/sbin/update-alternatives –config java

Digite o número que está na linha relacionada ao Java 6, dando Enter em seguida, como abaixo:

livre:/# /usr/sbin/update-alternatives –config java

Existem 3 alternativas que fornecem ‘java’.

Seleção      Alternativa
———————————————–
1    /usr/bin/gij-4.3
*+        2    /usr/lib/jvm/java-gcj/jre/bin/java
3    /usr/lib/jvm/java-6-sun/jre/bin/java

Pressione enter para manter o padrão[*] ou digite o número da seleção: 3
Usando ‘/usr/lib/jvm/java-6-sun/jre/bin/java’ para fornecer ‘java’.
###############################################

————–
* SAMBA *
————–

Para o SAMBA ficar bonitinho:

# apt-get install gvfs-backends libgnomevfs2-extra libsmbclient libsmbios2 libwbclient0 samba-common smbclient

Este tutorial teve varias fontes entre elas estão

http://www.guiadohardware.net/dicas/debian-lenny-desktop.html

Apreveitei muito adptando de http://hamacker.wordpress.com/ubuntu-perfeito-versao-804/

Eu também queria agradecer ao meu pai e a minha mãe, eu acho que sem eles eu não teria conseguido!!!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *